URI 1006 Problem Solve

URI Online Judge | 1006

Average 2

Read three values (variables A, B and C), which are the three student's grades. Then, calculate the average, considering that grade A has weight 2, grade B has weight 3 and the grade C has weight 5. Consider that each grade can go from 0 to 10.0, always with one decimal place.

Input

The input file contains 3 values of floating points with one digit after the decimal point.

Output

Print MEDIA(average in Portuguese) according to the following example, with a blank space before and after the equal signal.
Input SamplesOutput Samples
5.0
6.0
7.0
MEDIA = 6.3
5.0
10.0
10.0
MEDIA = 9.0
10.0
10.0
5.0
MEDIA = 7.5

Answer

#include<stdio.h>
int main()
{
    double A,B,C,sum,MEDIA;
    scanf("%lf %lf %lf",&A,&B,&C);
    sum=(A*2+B*3+C*5);
    MEDIA=sum/(2+3+5);
    printf("MEDIA = %.1lf\n",MEDIA);
    return 0;
}

Comments